MSA-20-0010: yui_combo should mitigate denial of service risk

by Michael Hawkins.  

yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.


Severity/Risk:Serious
Versions affected:3.9, 3.8 to 3.8.3, 3.7 to 3.7.6, 3.5 to 3.5.12 and earlier unsupported versions
Versions fixed:3.9.1, 3.8.4, 3.7.7 and 3.5.13
Reported by:Yuri Zwaig
CVE identifier:CVE-2020-14322
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-68426
Tracker issue:MDL-68426 yui_combo should mitigate denial of service risk

Read more https://moodle.org/mod/forum/discuss.php?d=407394&parent=1644269