MSA-20-0004: Admin PHP unit webrunner tool requires additional input escaping

by Michael Hawkins.  

Insufficient input escaping was applied to the PHP unit webrunner admin tool.

NOTE: It is important to note that this update is only flagged as a precautionary measure, as it may provide limited CLI access to Moodle site admins. This may be considered a security risk in circumstances where admins do not ordinarily have access to the server CLI and/or in some hosting situations where site admins are not considered trusted users. This tool will also be removed entirely from Moodle 3.9.


Severity/Risk:Minor
Versions affected:3.8 to 3.8.1, 3.7 to 3.7.4, 3.6 to 3.6.8, 3.5 to 3.5.10 and earlier unsupported versions
Versions fixed:3.8.2, 3.7.5, 3.6.9 and 3.5.11
Reported by:Brendan Heywood
CVE identifier:CVE-2020-1756
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-67726
Tracker issue:MDL-67726 Admin PHP unit webrunner tool requires additional input escaping

Read more https://moodle.org/mod/forum/discuss.php?d=398352&parent=1606856