MSA-20-0001: Stored XSS in message conversation overview

by Michael Hawkins.  

Messages required extra sanitizing before updating the conversation overview, to prevent the risk of stored XSS.


Severity/Risk:Serious
Versions affected:3.8
Versions fixed:3.8.1
Reported by:Cid da Costa
Workaround:Disable the messaging system until the patch has been applied.
CVE identifier:CVE-2020-1691
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-67637
Tracker issue:MDL-67637 Stored XSS in message conversation overview

Read more https://moodle.org/mod/forum/discuss.php?d=395953&parent=1596360