MSA-19-0029: Reflected XSS possible from some fatal error messages

by Michael Hawkins.  

Fatal error messages required extra sanitizing to prevent reflected XSS risks on some pages.


Severity/Risk:Serious
Versions affected:3.7 to 3.7.2, 3.6 to 3.6.6, 3.5 to 3.5.8 and earlier unsupported versions
Versions fixed:3.7.3, 3.6.7 and 3.5.9
Reported by:Yuriy Dyachenko
CVE identifier:CVE-2019-14884
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-66161
Tracker issue:MDL-66161 Reflected XSS possible from some fatal error messages

Read more https://moodle.org/mod/forum/discuss.php?d=393587&parent=1586751