MSA-19-0018: JavaScript injection possible in some Mustache templates via recursive rendering from contexts

by Michael Hawkins.  

Mustache helper tags that were included in template contexts were not being escaped before that context was injected into another Mustache helper, which could result in script injection in some templates.


Severity/Risk:Serious
Versions affected:3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions
Versions fixed:3.7.2, 3.6.6 and 3.5.8
Reported by:Sam Hemelryk, Andrew Nicols
CVE identifier:CVE-2019-14827
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62284
Tracker issue:MDL-62284 JavaScript injection possible in some Mustache templates via recursive rendering from contexts

Read more https://moodle.org/mod/forum/discuss.php?d=391030&parent=1576204