MSA-17-0003: PHPMailer vulnerability in no-reply address

by Marina Glancy.  

Description:Security vulnerability was reported against PHPMailer, third party library used by Moodle. As a result Moodle improved validation of no-reply address (that can only be configured by admin), all other fields were already properly sanitized. This issue only affect sites that leave $CFG->smtphosts empty.
Issue summary:Address the vulnerabilities in recent PHPMailer 5.2.x
Severity/Risk:Serious
Versions affected:3.2, 3.1 to 3.1.3, 3.0 to 3.0.7, 2.9 to 2.9.9, 2.8 to 2.8.12, 2.7 to 2.7.17 and earlier unsupported versions
Versions fixed:3.2.1, 3.1.4, 3.0.8 and 2.7.18
Reported by:Matteo Scaramuccia
Issue no.:MDL-57531
Workaround:Define $CFG->noreplyaddress and $CFG->supportemail in config.php
CVE identifier:CVE-2016-10045 (PHPMailer)
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-57531

Read more https://moodle.org/mod/forum/discuss.php?d=345914&parent=1395033